Xoops 2.5.6 Multiple XSS vulnerabilities

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1044447 漏洞类型
发布时间 2013-09-09 更新时间 2013-09-09
CVE编号 N/A CNNVD-ID N/A
漏洞平台 N/A CVSS评分 N/A
|漏洞来源
https://cxsecurity.com/issue/WLB-2013090066
|漏洞详情
漏洞细节尚未披露
|漏洞EXP
Xoops 2.5.6 Multiple XSS vulnerabilities
------------------------------------------------------------
 
== Description  ==
- Software link: http://xoops.org/
- Affected versions: version 2.5.6(last version) is vulnerable. Other
versions might be affected as well.
- Vulnerability discovered by: Mehdi Dadkhah (Isfahan mehdidadkhah@live.com)
-Google Dork: intext:"Powered by XOOPS © 2001-2013"
My site for more Discription:http://IIST.IR
== VulnerabilitiesWith Proof of concept  ==
Cross site scripting (also referred to as XSS) is a vulnerability that allows an attacker to send malicious code (usually in the form of Javascript) 
to another user. Because a browser cannot know if the script should be trusted or not, it will execute the script in the user context allowing the 
attacker to access any cookies or session tokens retained by the browser. 
[+]Affected items:
[URL OF SITE]/banners.php 
[URL OF SITE]/register.php 
[URL OF SITE]/user.php 

[+]Attack details
URI was set to "onmouseover='prompt(930269)'bad=">
The input is reflected inside a tag parameter between double quotes.

Malicious users may inject JavaScript, VBScript, ActiveX, HTML or Flash into a vulnerable application to fool a user in order to gather data from them.
An attacker can steal the session cookie and take over the account, impersonating the user. It is also possible to modify the content of the page presented
to the user. 


== Solution ==
Your script should filter metacharacters from user input.