PHP 4.3.x/5.0 - 'openlog()' Buffer Overflow

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1053790 漏洞类型
发布时间 2003-03-27 更新时间 2003-03-27
CVE编号 N/A CNNVD-ID N/A
漏洞平台 PHP CVSS评分 N/A
|漏洞来源
https://www.exploit-db.com/exploits/22435
|漏洞详情
漏洞细节尚未披露
|漏洞EXP
source: http://www.securityfocus.com/bid/7210/info

A buffer overflow has been reported in the PHP openlog() function. By passing an argument of excessive size to the function, it may be possible for an attacker to overwrite memory, resulting in a denial of service. It is also possible for an attacker to execute arbitrary code in the PHP interpreter.

This vulnerability was reported for PHP 4.3.1 and later, however it is likely that previous versions are also affected. This issue appears to affect all platforms PHP runs on. 

<?php
openlog(str_repeat("X", 1500), LOG_PID, LOG_DAEMON);
?>