WordPress 0.6/0.7 - 'Blog.header.php' SQL Injection

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1054208 漏洞类型
发布时间 2003-10-03 更新时间 2003-10-03
CVE编号 N/A CNNVD-ID N/A
漏洞平台 PHP CVSS评分 N/A
|漏洞来源
https://www.exploit-db.com/exploits/23213
|漏洞详情
漏洞细节尚未披露
|漏洞EXP
source: http://www.securityfocus.com/bid/8756/info

Wordpress has been reported prone to multiple SQL injection vulnerabilities. The issues have been reported to exist in the blog.header.php script. A lack of sufficient sanitization performed on 'cat' and 'order_by' URI parameters, may allow an attacker to inject malicious SQL code and thereby influence legitimate Wordpress SQL queries.

Ultimately an attacker may exploit this vulnerability to insert SQL code into Wordpress requests and have the SQL code executed by the underlying database server.

http://www.example.com/index.php?cat=100)%09or%090=0%09or%09(0=1