iBoutique eCommerce 4.0 - Multiple Web Vulnerabilities

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1063881 漏洞类型
发布时间 2012-06-19 更新时间 2012-06-19
CVE编号 N/A CNNVD-ID N/A
漏洞平台 PHP CVSS评分 N/A
|漏洞来源
https://www.exploit-db.com/exploits/19292
|漏洞详情
漏洞细节尚未披露
|漏洞EXP
Title:
======
iBoutique eCommerce v4.0 - Multiple Web Vulnerabilites


Date:
=====
2012-06-09


References:
===========
http://www.vulnerability-lab.com/get_content.php?id=594


VL-ID:
=====
594


Common Vulnerability Scoring System:
====================================
8


Introduction:
=============
iBoutique is a PHP ecommerce solution that allows you to setup and maintain your own estore. Features include simple user interface, 
easy product detail maintenance, shoping carts, template managing, statistic reporting, and much more.

(Copy of the Vendor Homepage: http://www.netartmedia.net/iboutique  ) 


Abstract:
=========
The Vulnerability Laboratory Research Team discovered multiple web vulnerabilities in iBoutique CMS v4.0 flexible e-commerce system.



Report-Timeline:
================
2012-06-09:	Public or Non-Public Disclosure


Status:
========
Published


Exploitation-Technique:
=======================
Remote


Severity:
=========
Critical


Details:
========
1.1
An SQL Injection vulnerability is detected in iBoutique v4.0, flexible e-commerce system.
The vulnerability allows an attacker (remote) or local low privileged user account to inject/execute his sql commands 
on the affected application DBMS. Successful exploitation of the vulnerability results in dbms & application compromise.
The vulnerability is located in the vulnerable OrderNumber parameter request of the index.php file.

Vulnerable File(s):
                          [+] index.php

Vulnerable Parameter(s):
                          [+] ?page=en_Orders&OrderNumber=

--- SQL Exception Logs ---
SQL_ERROR

select * from websiteadmin_orders WHERE OrderNumber=254` AND UserName=`hack`
You have an error in your SQL syntax; 
check the manual that corresponds to your MySQL server version for the right syntax to use near `AND UserName=`hack` at line 1
Details for order #254`


1.2
A persistent input validation vulnerability is detected in iBoutique v4.0.
The bugs allow remote attackers to implement/inject malicious script code on the application side (persistent). 
Successful exploitation of the vulnerability can lead to session hijacking (manager/admin) or stable (persistent) 
context manipulation. Exploitation requires low user inter action & privileged user account. 
The persistent vulnerability is located in the first name input field  value & output display of the 
vulnerable ?page=en_Profile

Vulnerable Module(s):
                          [+] index.php?page=en_Profile&edit=1 - [First Name] - [Last Name] - [Country] - [State] - [Address 1] - [Email]


Proof of Concept:
=================
The sql injection vulnerability can be exploited by remote attackers without user inter action. For demonstration or reproduce ...

1.1
http://127.0.0.1:1338/iboutique/index.php?page=en_Orders&OrderNumber=258'+/*!Union*/+/*!SelEct*/+1,2,3,4,version(),6,7,8,9,10--%20-

1.2
The persistent input validation vulnerabilities can be exploited by remote attackers with low required user inter action.
For demonstration or reproduce ...

The attacker create an account and then changed his first name, last name, email, state, address, etc..  to malicious html code.
To change, the first name the attacker needs to go to  my area > my profile > edit profile
then inject a malicious code i.e., <iframe src=www.vuln-lab.com onload=alert("VL")/>
When the admin browses the payments page in the control panel the persistent injected code will be executed out of the web context.



Risk:
=====
1.1
The security risk of the sql injection vulnerability is estimated as critical.

1.2
The security risk of the persistent input validation vulnerabilities are estiamted as medium(+)



Credits:
========
Vulnerability Laboratory [Research Team]  -    Ibrahim El-Sayed [the StOrM) (storm@vulnerability-lab.com)


Disclaimer:
===========
The information provided in this advisory is provided as it is without any warranty. Vulnerability-Lab disclaims all warranties, 
either expressed or implied, including the warranties of merchantability and capability for a particular purpose. Vulnerability-
Lab or its suppliers are not liable in any case of damage, including direct, indirect, incidental, consequential loss of business 
profits or special damages, even if Vulnerability-Lab or its suppliers have been advised of the possibility of such damages. Some 
states do not allow the exclusion or limitation of liability for consequential or incidental damages so the foregoing limitation 
may not apply. 

Domains:	www.vulnerability-lab.com   	- www.vuln-lab.com
Contact:	admin@vulnerability-lab.com 	- support@vulnerability-lab.com 	- research@vulnerability-lab.com
Section:	video.vulnerability-lab.com 	- forum.vulnerability-lab.com 		- news.vulnerability-lab.com
Social:		twitter.com/#!/vuln_lab 	- facebook.com/VulnerabilityLab 	- youtube.com/user/vulnerability0lab

Any modified copy or reproduction, including partially usages, of this file requires authorization from Vulnerability Laboratory. 
Permission to electronically redistribute this alert in its unmodified form is granted. All other rights, including the use of other 
media, are reserved by Vulnerability-Lab Research Team or its suppliers. All pictures, texts, advisories, sourcecode, videos and 
other information on this website is trademark of vulnerability-lab team & the specific authors or managers. To record, list (feed), 
modify, use or edit our material contact (admin@vulnerability-lab.com or support@vulnerability-lab.com) to get a permission.

    						Copyright 2012 Vulnerability-Lab



-- 
VULNERABILITY RESEARCH LABORATORY TEAM
Website: www.vulnerability-lab.com
Mail: research@vulnerability-lab.com