myPHPNuke Links.php跨站脚本漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1107213 漏洞类型 跨站脚本
发布时间 2003-02-20 更新时间 2003-12-31
CVE编号 CVE-2003-1372 CNNVD-ID CNNVD-200312-314
漏洞平台 PHP CVSS评分 4.3
|漏洞来源
https://www.exploit-db.com/exploits/22268
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-200312-314
|漏洞详情
myPHPNuke1.8.8,可能还有其他早期版本的links.php脚本存在跨站脚本(XSS)漏洞。远程攻击者借助(1)ratenum或者(2)query参数注入任意HTML和web脚本。
|漏洞EXP
source: http://www.securityfocus.com/bid/6892/info

Reportedly, myPHPNuke 'links.php' does not adequately filter HTML code thus making it prone to cross-site scripting attacks. It is possible for a remote attacker to create a malicious link containing script code that will be executed in the browser of a legitimate user. All code will be executed within the context of the website running myPHPNuke.

This issue may be exploited to steal cookie-based authentication credentials from legitimate users of the website running the vulnerable software.

This vulnerability was reported for myPHPNuke 1.8.8 earlier versions may also be affected.

http://www.example.com/myphpnuke/links.php?op=MostPopular&ratenum=[scr!pt]alert(document.cookie);[/scr!pt]&ratetype=percent

http://www.example.com/myphpnuke/links.php?op=search&query=[scr!pt]alert('tacettin@olympos.org');[/scr!pt]?query=
|参考资料

来源:XF
名称:phpbb-index-sql-injection(11376)
链接:http://xforce.iss.net/xforce/xfdb/11376
来源:BID
名称:6892
链接:http://www.securityfocus.com/bid/6892
来源:BUGTRAQ
名称:20030219myphpnukexss
链接:http://archives.neohapsis.com/archives/bugtraq/2003-02/0231.html
来源:OSVDB
名称:3931
链接:http://www.osvdb.org/3931
来源:SECUNIA
名称:8125
链接:http://secunia.com/advisories/8125