APT-webshop-system modules.php 多个SQL注入漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1108641 漏洞类型 SQL注入
发布时间 2005-04-10 更新时间 2006-04-11
CVE编号 CVE-2006-1685 CNNVD-ID CNNVD-200604-115
漏洞平台 PHP CVSS评分 7.5
|漏洞来源
https://www.exploit-db.com/exploits/27590
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-200604-115
|漏洞详情
APT-webshop-system4.0PRO,3.0BASIC及3.0LIGHT中的modules.php存在多个SQL注入漏洞。这使得远程攻击者可以借助于参数(1)group,(2)seite和(3)id执行任意SQL命令。该漏洞可能涉及artikel功能。注:当SQL查询无效时,该漏洞也可能造成结果路径泄露。
|漏洞EXP
source: http://www.securityfocus.com/bid/17425/info

APT-webshop is prone to multiple SQL-injection vulnerabilities. These issues are due to a failure in the application to properly sanitize user-supplied input before using it in an SQL query. 

A successful exploit could allow an attacker to compromise the application, access or modify data, or exploit vulnerabilities in the underlying database implementation.

APT-webshop 3.0 light, 3.0 basic, and 4.0 pro are reported prone to these issues. Other versions may be vulnerable as well.

http://www.example.com/modules.php?warp=artikel&group=[SQL]
http://www.example.com/modules.php?warp=artikel&group=&seite=[SQL]
http://www.example.com/modules.php?warp=artikel&group=&seite=&id=[SQL]
|参考资料

来源:VUPEN
名称:ADV-2006-1293
链接:http://www.frsirt.com/english/advisories/2006/1293
来源:SECUNIA
名称:19592
链接:http://secunia.com/advisories/19592
来源:XF
名称:apt-webshop-sql-injection(25731)
链接:http://xforce.iss.net/xforce/xfdb/25731
来源:BID
名称:17425
链接:http://www.securityfocus.com/bid/17425
来源:MISC
链接:http://pridels0.blogspot.com/2006/04/apt-webshop-system-vuln.html