phpBook guestbook.php 跨站脚本漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1108945 漏洞类型 跨站脚本
发布时间 2005-07-26 更新时间 2007-07-06
CVE编号 CVE-2005-2397 CNNVD-ID CNNVD-200507-282
漏洞平台 PHP CVSS评分 4.3
|漏洞来源
https://www.exploit-db.com/exploits/26034
https://www.securityfocus.com/bid/14390
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-200507-282
|漏洞详情
phpbook是一个基于php开发的网络留言薄程序。phpBook1.46版本的guestbook.php存在跨站脚本(XSS)漏洞。远程攻击者可以通过admin参数注入任意Web脚本或HTML。
|漏洞EXP
source: http://www.securityfocus.com/bid/14390/info

NETonE PHPBook is prone to a cross-site scripting vulnerability because the application fails to properly sanitize user-supplied input to the 'admin' parameter of the 'guestbook.php' script.

A successful exploit could allow an attacker to steal cookie-based authentication credentials and launch other attacks. 

http://www.example/com/guestbook.php?admin="><script>alert(document.cookie)</script><!--
|受影响的产品
NETonE GuestBook 1.4.6
|参考资料

来源:SECTRACK
名称:1014573
链接:http://securitytracker.com/id?1014573
来源:XF
名称:phpbook-admin-xss(21538)
链接:http://xforce.iss.net/xforce/xfdb/21538
来源:BID
名称:14390
链接:http://www.securityfocus.com/bid/14390
来源:OSVDB
名称:18295
链接:http://www.osvdb.org/18295
来源:SECUNIA
名称:16192
链接:http://secunia.com/advisories/16192