ATutor多个PHP文件包含漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1109176 漏洞类型 输入验证
发布时间 2005-10-27 更新时间 2006-08-23
CVE编号 CVE-2005-3404 CNNVD-ID CNNVD-200511-039
漏洞平台 PHP CVSS评分 7.5
|漏洞来源
https://www.exploit-db.com/exploits/26432
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-200511-039
|漏洞详情
ATutor是ATutor团队开发的一套开源的基于Web的学习内容管理系统(LCMS)。该系统包括教学内容管理、论坛、聊天室等模块。在ATutor1.4.1直到1.5.1-pl1中存在多个PHP文件包含漏洞,这允许远程攻击者通过在页面(1)body_header.inc.php和(2)print.php的section参数后面跟一个空字节(%00)来包含任意的文件。
|漏洞EXP
source: http://www.securityfocus.com/bid/15221/info
 
ATutor is prone to multiple vulnerabilities.
 
These issues can allow remote attackers to execute arbitrary PHP commands and carry out local file include and cross-site scripting attacks.
 
ATutor 1.5.1-pl1 and prior versions are affected. 

http://www.example.com/documentation/common/body_header.inc.php?section=[file]%00
|参考资料

来源:BID
名称:15221
链接:http://www.securityfocus.com/bid/15221
来源:OSVDB
名称:20346
链接:http://www.osvdb.org/20346
来源:OSVDB
名称:20345
链接:http://www.osvdb.org/20345
来源:VUPEN
名称:ADV-2005-2228
链接:http://www.frsirt.com/english/advisories/2005/2228
来源:MISC
链接:http://secunia.com/secunia_research/2005-55/advisory/
来源:SECUNIA
名称:16915
链接:http://secunia.com/advisories/16915/
来源:BUGTRAQ
名称:20051027SecuniaResearch:ATutorMultipleVulnerabilities
链接:http://marc.theaimsgroup.com/?l=bugtraq&m=113043022821049&w=2
来源:SECTRACK
名称:1015165
链接:http://securitytracker.com/id?1015165
来源:SREASON
名称:123
链接:http://securityreason.com/securityalert/123