phpFaber CMS 'Htmlarea.PHP'跨站脚本攻击漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1109181 漏洞类型 跨站脚本
发布时间 2005-10-30 更新时间 2006-11-09
CVE编号 CVE-2006-5626 CNNVD-ID CNNVD-200610-541
漏洞平台 PHP CVSS评分 4.3
|漏洞来源
https://www.exploit-db.com/exploits/28882
https://cxsecurity.com/issue/WLB-2006110005
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-200610-541
|漏洞详情
phpFaberContentManagementSystem(CMS)的cms_images/js/htmlarea/htmlarea.php中存在跨站脚本攻击漏洞,远程攻击者可能通过查询字符串中的任意参数注入任意Web脚本或HTML,例如通过vigilon参数即可触发此漏洞。
|漏洞EXP
source: http://www.securityfocus.com/bid/20821/info

phpFaber CMS is prone to a cross-site scripting vulnerability because the application fails to properly sanitize user-supplied input. 

An attacker may leverage this issue to have arbitrary script code execute in the browser of an unsuspecting user in the context of the affected site. This may help the attacker steal cookie-based authentication credentials and launch other attacks.

This issue affects version 1.3.36; earlier versions may also be vulnerable.

http://www.example.com/cms_images/js/htmlarea/htmlarea.php?vigilon=>"><ScRiPt>alert("XSS")</ScRiPt>
|参考资料

来源:MISC
链接:http://www.vigilon.com/resources/102506c.html
来源:BUGTRAQ
名称:20061026phpFaberCMSCrossSiteScripting
链接:http://www.securityfocus.com/archive/1/archive/1/449894/100/0/threaded
来源:SECUNIA
名称:22629
链接:http://secunia.com/advisories/22629
来源:BID
名称:20821
链接:http://www.securityfocus.com/bid/20821
来源:VUPEN
名称:ADV-2006-4260
链接:http://www.frsirt.com/english/advisories/2006/4260
来源:SREASON
名称:1802
链接:http://securityreason.com/securityalert/1802