Mantis View_filters_page.PHP 跨站脚本攻击漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1109440 漏洞类型 跨站脚本
发布时间 2005-12-13 更新时间 2006-06-27
CVE编号 CVE-2005-4238 CNNVD-ID CNNVD-200512-259
漏洞平台 PHP CVSS评分 4.3
|漏洞来源
https://www.exploit-db.com/exploits/26798
https://www.securityfocus.com/bid/15842
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-200512-259
|漏洞详情
Mantis1.0.0rc3及更早版本中的view_filters_page.php存在跨站脚本攻击漏洞,远程攻击者可以通过target_field参数注入任意Web脚本或HTML。
|漏洞EXP
source: http://www.securityfocus.com/bid/15842/info

Mantis is prone to a cross-site scripting vulnerability. This issue is due to a failure in the application to properly sanitize user-supplied input.

An attacker may leverage this issue to have arbitrary script code execute in the browser of an unsuspecting user in the context of the affected site. This may help the attacker steal cookie-based authentication credentials and launch other attacks. 

http://www.example.com/view_filters_page.php?for_screen=1&target_field=%22%3E%3Cscript%3Ealert('r0t')%3C/script%3E
|受影响的产品
Mantis Mantis 1.0 .0RC3 Mantis Mantis 1.0 .0rc2 Mantis Mantis 1.0 .0rc1 Mantis Mantis 1.0 .0a3 Mantis Mantis 1.0 .0a2 Mantis Mantis 1.0 .0a1 Mantis Mantis 0.19
|参考资料

来源:BID
名称:15842
链接:http://www.securityfocus.com/bid/15842
来源:VUPEN
名称:ADV-2005-2874
链接:http://www.frsirt.com/english/advisories/2005/2874
来源:DEBIAN
名称:DSA-944
链接:http://www.debian.org/security/2005/dsa-944
来源:SECUNIA
名称:18481
链接:http://secunia.com/advisories/18481
来源:SECUNIA
名称:18018
链接:http://secunia.com/advisories/18018
来源:MISC
链接:http://pridels0.blogspot.com/2005/12/mantis-bugtracking-system-xss-vuln.html