Plogger Index.PHP跨站脚本攻击漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1109444 漏洞类型 跨站脚本
发布时间 2005-12-13 更新时间 2005-12-14
CVE编号 CVE-2005-4247 CNNVD-ID CNNVD-200512-291
漏洞平台 PHP CVSS评分 4.3
|漏洞来源
https://www.exploit-db.com/exploits/26794
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-200512-291
|漏洞详情
PloggerBeta2及其更早版本中的index.php存在跨站脚本攻击漏洞。远程攻击者可以借助searchterms参数注入任意的Web脚本或HTML。
|漏洞EXP
source: http://www.securityfocus.com/bid/15839/info
 
Plogger is prone to multiple input validation vulnerabilities. These issues are due to a failure in the application to properly sanitize user-supplied input.
 
Successful exploitation of these vulnerabilities could result in a compromise of the application, disclosure or modification of data, the theft of cookie-based authentication credentials or may permit an attacker to exploit vulnerabilities in the underlying database implementation as well as other attacks. 

http://www.example.com/index.php?level=%22%3E%3Cscript%3Ealert('r0t')%3C/script%3E

http://www.example.com/index.php?level=search&searchterms=%22%3E%3Cscript%3Ealert('r0t')%3C/script%3E
|参考资料

来源:BID
名称:15839
链接:http://www.securityfocus.com/bid/15839
来源:OSVDB
名称:21711
链接:http://www.osvdb.org/21711
来源:MISC
链接:http://pridels0.blogspot.com/2005/12/plogger-sqlxss-vuln.html