WordPress 跨站脚本攻击漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1109763 漏洞类型 跨站脚本
发布时间 2006-02-15 更新时间 2006-02-24
CVE编号 CVE-2006-0733 CNNVD-ID CNNVD-200602-236
漏洞平台 PHP CVSS评分 2.6
|漏洞来源
https://www.exploit-db.com/exploits/27227
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-200602-236
|漏洞详情
**有争议**WordPress2.0.0中存在跨站脚本攻击(XSS)漏洞。远程攻击者可以借助可编写脚本的属性,如"作者网站"字段中的(1)onfocus和(2)onblur属性注入任意Web脚本或HTML。注意:对研究员web日志的后续评论说明此问题只能被注入XSS的同一用户利用,因此可能不是漏洞。
|漏洞EXP
source: http://www.securityfocus.com/bid/16656/info

WordPress is prone to an HTML-injection vulnerability. 

Attacker-supplied HTML and script code would be executed in the context of the affected website, potentially allowing for the theft of cookie-based authentication credentials. An attacker could also exploit this issue to control how the site is rendered to the user; other attacks are also possible.

WordPress version 2.0.0 is reportedly vulnerable; other versions may also be affected.

An example has been provided:

<strong>author's website</strong>:
<strong>" onfocus="alert(1)" onblur="alert(1)</strong>
|参考资料

来源:BID
名称:16656
链接:http://www.securityfocus.com/bid/16656
来源:BUGTRAQ
名称:20060214[myimei]WordPress2.0.0~autors?website~XSSattack
链接:http://www.securityfocus.com/archive/1/archive/1/425043/100/0/threaded
来源:MISC
链接:http://myimei.com/security/2006-02-15/wordpress200autors-websitexss-attack.html
来源:XF
名称:wordpress-authorswebsite-xss(24736)
链接:http://xforce.iss.net/xforce/xfdb/24736