ActiveCampaign KnowledgeBase搜索模块不明参数跨站脚本攻击漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1109954 漏洞类型 跨站脚本
发布时间 2006-03-27 更新时间 2007-08-27
CVE编号 CVE-2006-1487 CNNVD-ID CNNVD-200603-460
漏洞平台 PHP CVSS评分 4.3
|漏洞来源
https://www.exploit-db.com/exploits/27492
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-200603-460
|漏洞详情
在ActiveCampaignSupportTrio2.50.2中存在跨站脚本攻击(XSS)漏洞,远程攻击者可通过用于KnowledgeBase搜索模块的不明参数,注入任意Web脚本或HTML。
|漏洞EXP
ActiveCampaign SupportTrio is prone to multiple cross-site scripting vulnerabilities. These issues are due to a failure in the application to properly sanitize user-supplied input. 

An attacker may leverage these issues to have arbitrary script code executed in the browser of an unsuspecting user in the context of the affected site. This may help the attacker steal cookie-based authentication credentials and launch other attacks.

ActiveCampaign SupportTrio 2.50.2 is vulnerable. Other versions may be affected as well.

http://www.example.com/supporttrio/index.php?action=kb&article=[r0t]
http://www.example.com/supporttrio/index.php?action=kb&print=[r0t]
http://www.example.com/supporttrio/modules/KB/pdf.php?category=[r0t]
|参考资料

来源:XF
名称:supporttrio-search-xss(25495)
链接:http://xforce.iss.net/xforce/xfdb/25495
来源:BID
名称:17276
链接:http://www.securityfocus.com/bid/17276
来源:OSVDB
名称:24192
链接:http://www.osvdb.org/24192
来源:VUPEN
名称:ADV-2006-1126
链接:http://www.frsirt.com/english/advisories/2006/1126
来源:SECUNIA
名称:19431
链接:http://secunia.com/advisories/19431
来源:MISC
链接:http://pridels0.blogspot.com/2006/03/activecampaign-supporttrio-25-vuln.html