Calendarix YearCal.PHP 跨站脚本攻击漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1110078 漏洞类型 跨站脚本
发布时间 2006-04-17 更新时间 2006-04-20
CVE编号 CVE-2006-1835 CNNVD-ID CNNVD-200604-307
漏洞平台 PHP CVSS评分 2.6
|漏洞来源
https://www.exploit-db.com/exploits/27665
https://cxsecurity.com/issue/WLB-2006040056
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-200604-307
|漏洞详情
Calendarix中的yearcal.php存在跨站脚本攻击漏洞。这使得远程攻击者可以借助于ycyear参数注入任意Web脚本或HTML。
|漏洞EXP
source: http://www.securityfocus.com/bid/17562/info

Calendarix is prone to a cross-site scripting vulnerability because it fails to properly sanitize user-supplied input. 

An attacker may leverage this issue to have arbitrary script code executed in the browser of an unsuspecting user in the context of the affected site. This may help the attacker steal cookie-based authentication credentials and launch other attacks.

Specific information regarding affected versions of Calendarix is currently unavailable.

http://www.example.com/[path]/yearcal.php?ycyear=<script>alert(document.cookie)</script>
|参考资料

来源:BID
名称:17562
链接:http://www.securityfocus.com/bid/17562
来源:BUGTRAQ
名称:20060416Calendarix"yearcal.php"XSSAttacking
链接:http://www.securityfocus.com/archive/1/archive/1/431122/100/0/threaded
来源:XF
名称:calendarix-yearcal-xss(25874)
链接:http://xforce.iss.net/xforce/xfdb/25874
来源:VUPEN
名称:ADV-2006-1376
链接:http://www.frsirt.com/english/advisories/2006/1376
来源:SECTRACK
名称:1015954
链接:http://securitytracker.com/id?1015954
来源:SREASON
名称:727
链接:http://securityreason.com/securityalert/727
来源:SECUNIA
名称:19710
链接:http://secunia.com/advisories/19710