PerlCoders BannerFarm banners.cgi 多个跨站脚本攻击漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1110095 漏洞类型 跨站脚本
发布时间 2006-04-19 更新时间 2006-04-25
CVE编号 CVE-2006-1950 CNNVD-ID CNNVD-200604-382
漏洞平台 CGI CVSS评分 4.3
|漏洞来源
https://www.exploit-db.com/exploits/27689
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-200604-382
|漏洞详情
PerlCodersBannerFarm2.3及早期版本中的banners.cgi存在多个跨站脚本攻击漏洞。这使得远程攻击者可以借助于参数(1)aff和(2)cat注入任意Web脚本或HTML。
|漏洞EXP
source: http://www.securityfocus.com/bid/17613/info

BannerFarm is prone to multiple cross-site scripting vulnerabilities. These issues are due to a failure in the application to properly sanitize user-supplied input. 

An attacker may leverage these issues to have arbitrary script code executed in the browser of an unsuspecting user in the context of the affected site. This may help the attacker steal cookie-based authentication credentials and launch other attacks.

Version 2.3 of BannerFarm is vulnerable to these issues; other versions may also be affected.

http://www.example.com/banners.cgi?aff=[XSS]
http://www.example.com/banners.cgi?aff=&cat=[XSS]
|参考资料

来源:BID
名称:17613
链接:http://www.securityfocus.com/bid/17613
来源:VUPEN
名称:ADV-2006-1410
链接:http://www.frsirt.com/english/advisories/2006/1410
来源:SECUNIA
名称:19718
链接:http://secunia.com/advisories/19718
来源:XF
名称:bannerfarm-banners-xss(25919)
链接:http://xforce.iss.net/xforce/xfdb/25919
来源:OSVDB
名称:24728
链接:http://www.osvdb.org/24728
来源:MISC
链接:http://pridels0.blogspot.com/2006/04/bannerfarm-xss-vuln.html