Manic Web MWGuest MWguest.PHP 跨站脚本攻击漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1110107 漏洞类型 跨站脚本
发布时间 2006-04-20 更新时间 2006-04-25
CVE编号 CVE-2006-1979 CNNVD-ID CNNVD-200604-430
漏洞平台 PHP CVSS评分 5.8
|漏洞来源
https://www.exploit-db.com/exploits/27713
https://cxsecurity.com/issue/WLB-2006040073
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-200604-430
|漏洞详情
ManicWebMWGuest2.1.0中的mwguest.php存在跨站脚本攻击漏洞。这使得远程攻击者可以借助于homepage参数注入任意Web脚本或HTML。
|漏洞EXP
source: http://www.securityfocus.com/bid/17630/info

MWGuest is prone to an HTML-injection vulnerability because the application fails to properly sanitize user-supplied input before using it in dynamically generated content. 

Attacker-supplied HTML and script code would be executed in the context of the affected website, potentially allowing an attacker to steal cookie-based authentication credentials or to control how the site is rendered to the user. Other attacks are also possible. 

Version 2.1.0 is vulnerable. Prior versions may be vulnerable as well.

URL: http://www.example.com/mwguest/mwguest.php
Homepage: ">[XSS]<aaa aaa="
|参考资料

来源:BID
名称:17630
链接:http://www.securityfocus.com/bid/17630
来源:BUGTRAQ
名称:20060420[eVuln]MWGuestXSSVulnerability
链接:http://www.securityfocus.com/archive/1/archive/1/431507/100/0/threaded
来源:MISC
链接:http://evuln.com/vulns/122/summary.html
来源:XF
名称:mwguest-mwguest-xss(25674)
链接:http://xforce.iss.net/xforce/xfdb/25674
来源:SREASON
名称:747
链接:http://securityreason.com/securityalert/747