Singapore Index.PHP 跨站脚本攻击漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1110235 漏洞类型 跨站脚本
发布时间 2006-05-08 更新时间 2006-05-10
CVE编号 CVE-2006-2262 CNNVD-ID CNNVD-200605-180
漏洞平台 PHP CVSS评分 2.6
|漏洞来源
https://www.exploit-db.com/exploits/27824
https://cxsecurity.com/issue/WLB-2006050051
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-200605-180
|漏洞详情
singapore0.9.7中的index.php脚本存在跨站脚本攻击漏洞,远程攻击者可通过image参数注入任意Web脚本或HTML。
|漏洞EXP
source: http://www.securityfocus.com/bid/17874/info

The 'singapore' application is prone to a cross-site scripting vulnerability. This issue is due to a failure in the application to properly sanitize user-supplied input. 

An attacker may leverage this issue to have arbitrary script code executed in the browser of an unsuspecting user in the context of the affected site. This may help the attacker steal cookie-based authentication credentials and launch other attacks.

http://www.example.com/images/index.php?gallery=[gallery name]&image=<iframe%20src="http://www.example.com">
http://www.example.com/images/index.php?gallery=[gallery name]&image=<script>alert("lol")<script>
|参考资料

来源:BID
名称:17874
链接:http://www.securityfocus.com/bid/17874
来源:BUGTRAQ
名称:20060508singaporev0.9.7XSSVulnerabilities
链接:http://www.securityfocus.com/archive/1/archive/1/433250/100/0/threaded
来源:MISC
链接:http://downloads.securityfocus.com/vulnerabilities/exploits/singapore-0.9.7-xss.txt
来源:XF
名称:singapore-index-image-xss(26352)
链接:http://xforce.iss.net/xforce/xfdb/26352
来源:www.sgal.org
链接:http://www.sgal.org/files/download/20060512-xss-patch.zip
来源:OSVDB
名称:25706
链接:http://www.osvdb.org/25706
来源:SECTRACK
名称:1016055
链接:http://securitytracker.com/id?1016055
来源:SREASON
名称:854
链接:http://securityreason.com/securityalert/854