CyBoards PHP Lite common.php 远程文件包含漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1110405 漏洞类型 输入验证
发布时间 2006-06-05 更新时间 2007-08-13
CVE编号 CVE-2006-2871 CNNVD-ID CNNVD-200606-137
漏洞平台 PHP CVSS评分 7.5
|漏洞来源
https://www.exploit-db.com/exploits/27970
https://cxsecurity.com/issue/WLB-2006060057
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-200606-137
|漏洞详情
CyboardsPHPLite是一款基于WEB的论坛程。CyboardsPHPLite的common.php文件中存在远程文件包含漏洞,远程攻击者可能利用此漏洞在服务器上执行任意命令。相关的漏洞代码如下:include("/home/www/forums/include/config.php");include($script_path."/db/mysql.php");
|漏洞EXP
source: http://www.securityfocus.com/bid/18272/info

CyBoards PHP Lite is prone to a remote file-include vulnerability.

An attacker can exploit this issue to include an arbitrary remote file containing malicious PHP code and execute it in the context of the webserver process. This may allow the attacker to compromise the application and the underlying system; other attacks are also possible.

Further analysis shows that the specified parameter is clearly defined. Therefore, this BID is being retired.

http://www.example.com/path/include/common.php?script_path=CmdShell
|参考资料

来源:XF
名称:cyboards-common-file-include(26962)
链接:http://xforce.iss.net/xforce/xfdb/26962
来源:BID
名称:18272
链接:http://www.securityfocus.com/bid/18272
来源:BUGTRAQ
名称:20060604CyBoardsPHPLitev1.25(common.PHP)RemoteFileInclusion
链接:http://www.securityfocus.com/archive/1/archive/1/435977/100/0/threaded
来源:OSVDB
名称:26596
链接:http://www.osvdb.org/26596
来源:VIM
名称:20070412dispute:olderCyBoardscommon.phpRFI(CVE-2006-2871)
链接:http://www.attrition.org/pipermail/vim/2007-April/001510.html
来源:SECTRACK
名称:1016225
链接:http://securitytracker.com/id?1016225
来源:SREASON
名称:1051
链接:http://securityreason.com/securityalert/1051