PHP Pro Bid 'auctionsearch.php'跨站脚本攻击(XSS)漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1110678 漏洞类型 跨站脚本
发布时间 2006-07-25 更新时间 2006-08-01
CVE编号 CVE-2006-3927 CNNVD-ID CNNVD-200607-510
漏洞平台 PHP CVSS评分 4.3
|漏洞来源
https://www.exploit-db.com/exploits/28274
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-200607-510
|漏洞详情
PhpProBid5.24的auctionsearch.php中存在跨站脚本攻击(XSS)漏洞。远程攻击者可以借助advsrc参数注入任意Web脚本或HTML。
|漏洞EXP
source: http://www.securityfocus.com/bid/19158/info

PHP Pro Bid is prone to multiple input-validation vulnerabilities, including cross-site scripting and SQL-injection issues, because the application fails to properly sanitize user-supplied input. 

A successful exploit of these vulnerabilities could allow an attacker to compromise the application, access or modify data, steal cookie-based authentication credentials, or even exploit vulnerabilities in the underlying database implementation. Other attacks are also possible.

Version 5.24 is vulnerable to these issues; other versions may also be affected.

http://www.example.com/auctionsearch.php?advsrc="<script>alert(/EllipsisSecurityTe st/)</script>
|参考资料

来源:XF
名称:php-pro-bid-auctionsearch-xss(28030)
链接:http://xforce.iss.net/xforce/xfdb/28030
来源:BID
名称:19158
链接:http://www.securityfocus.com/bid/19158
来源:OSVDB
名称:27544
链接:http://www.osvdb.org/27544
来源:SECTRACK
名称:1016595
链接:http://securitytracker.com/id?1016595
来源:SECUNIA
名称:21201
链接:http://secunia.com/advisories/21201
来源:BUGTRAQ
名称:20060725Phpprobid<=5.24XSSSQLinjectionVulnerability
链接:http://archives.neohapsis.com/archives/bugtraq/2006-07/0474.html
来源:SREASON
名称:1298
链接:http://securityreason.com/securityalert/1298