WP-DB Backup Wordpress 'wp-db-backup.php'目录遍历漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1110817 漏洞类型 路径遍历
发布时间 2006-08-14 更新时间 2006-08-24
CVE编号 CVE-2006-4208 CNNVD-ID CNNVD-200608-295
漏洞平台 PHP CVSS评分 5.0
|漏洞来源
https://www.exploit-db.com/exploits/28382
https://cxsecurity.com/issue/WLB-2006080110
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-200608-295
|漏洞详情
WordPress1.7及早期版本的SkippyWP-DB-Backup插件中的wp-db-backup.php脚本存在目录遍历漏洞,有管理员特权的远程认证用户可借助edit.php脚本的backup参数中(该参数中包含..)读取任意文件。
|漏洞EXP
source: http://www.securityfocus.com/bid/19504/info

WP-DB Backup For Wordpress is prone to a directory-traversal vulnerability because it fails to properly sanitize user-supplied input. 

An attacker can exploit this vulnerability to retrieve arbitrary files from the vulnerable system in the context of the affected application. Information obtained may aid in further attacks.

http://www.example.com/wp-admin/edit.php?page=wp-db-backup.php&backup=../../../../../etc/passwd
|参考资料

来源:XF
名称:wpdbbackup-edit-directory-traversal(28375)
链接:http://xforce.iss.net/xforce/xfdb/28375
来源:www.skippy.net
链接:http://www.skippy.net/blog/category/wordpress/plugins/wp-db-backup/
来源:BID
名称:19504
链接:http://www.securityfocus.com/bid/19504
来源:BUGTRAQ
名称:20060814WordpressWP-DBBackupPluginDirectoryTraversalVulnerability
链接:http://www.securityfocus.com/archive/1/archive/1/443181/100/0/threaded
来源:VUPEN
名称:ADV-2006-3280
链接:http://www.frsirt.com/english/advisories/2006/3280
来源:trac.wordpress.org
链接:http://trac.wordpress.org/changeset/4095
来源:SECUNIA
名称:21486
链接:http://secunia.com/advisories/21486
来源:SREASON
名称:1401
链接:http://securityreason.com/securityalert/1401