Reporter Mambo组件'Reporter.sql.PHP'远程文件包含漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1110829 漏洞类型 输入验证
发布时间 2006-08-16 更新时间 2006-08-22
CVE编号 CVE-2006-4241 CNNVD-ID CNNVD-200608-326
漏洞平台 PHP CVSS评分 7.5
|漏洞来源
https://www.exploit-db.com/exploits/28396
https://cxsecurity.com/issue/WLB-2006080128
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-200608-326
|漏洞详情
ReporterMambo组件(com_reporter)中的processor/reporter.sql.php脚本存在PHP远程文件包含漏洞,远程攻击者可借助mosConfig_absolute_path参数中的URL执行任意PHP代码。
|漏洞EXP
source: http://www.securityfocus.com/bid/19553/info

Reporter (a Mambo component) is prone to a remote file-include vulnerability because it fails to properly sanitize user-supplied input.

An attacker can exploit this issue to include arbitrary remote files containing malicious PHP code and execute it in the context of the webserver process. This may allow the attacker to compromise the application and to gain access to the underlying system.

http://www.example.com/[mambo_path]/components/com_reporter/processor/reporter.sql.php?mosConfig_absolute_path=
|参考资料

来源:XF
名称:reporter-reporter-sql-file-include(28412)
链接:http://xforce.iss.net/xforce/xfdb/28412
来源:BID
名称:19553
链接:http://www.securityfocus.com/bid/19553
来源:BUGTRAQ
名称:20060816ReporterMamboComponentRemoteFileİnclude
链接:http://www.securityfocus.com/archive/1/archive/1/443373/100/0/threaded
来源:SREASON
名称:1419
链接:http://securityreason.com/securityalert/1419