已过期: ToendaCMS 不明脚本TCMS_Administer参数远程文件包含漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1110869 漏洞类型 输入验证
发布时间 2006-08-21 更新时间 2006-09-19
CVE编号 CVE-2006-4349 CNNVD-ID CNNVD-200608-401
漏洞平台 PHP CVSS评分 7.5
|漏洞来源
https://www.exploit-db.com/exploits/28417
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-200608-401
|漏洞详情
**有争议**ToendaCMS1.0.3及早期版本中存在PHP远程文件包含漏洞,远程攻击者可借助提交到不明脚本(有可能是index.php脚本)中的tcms_administer_site参数中的URL执行任意PHP代码。注:第三方对此问题存在争议,称$tcms_administer_site参数在index.php脚本内部被初始化为常量。
|漏洞EXP
source: http://www.securityfocus.com/bid/19626/info

ToendaCMS is prone a remote file-include vulnerability because it fails to properly sanitize user-supplied input.

An attacker can exploit these issues to include an arbitrary remote file containing malicious PHP code and execute it in the context of the webserver process. This may allow the attacker to compromise the application and the underlying system; other attacks are also possible.

This issue affects ToendaCMS 1.0.3 and prior; other versions may also be affected.

Update: This BID is retired due to further analysis showing that this is not a vulnerability.

http://www.example.com/path/tcms_administer_site=SHELL
|参考资料

来源:XF
名称:toendacms-administersite-file-include(28491)
链接:http://xforce.iss.net/xforce/xfdb/28491
来源:BID
名称:19626
链接:http://www.securityfocus.com/bid/19626
来源:BUGTRAQ
名称:20060820ToendaCMS<=1.0.3-(tcms_administer_site)RemoteFileInclude
链接:http://www.securityfocus.com/archive/1/archive/1/443918/100/0/threaded
来源:BUGTRAQ
名称:20060823Re:ToendaCMS<=1.0.3-(tcms_administer_site)RemoteFileInclude
链接:http://www.securityfocus.com/archive/1/444236/100/0/threaded
来源:OSVDB
名称:29358
链接:http://www.osvdb.org/29358