XHP CMS 'Index.PHP'跨站脚本攻击漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1110997 漏洞类型 跨站脚本
发布时间 2006-09-11 更新时间 2006-09-18
CVE编号 CVE-2006-4751 CNNVD-ID CNNVD-200609-216
漏洞平台 PHP CVSS评分 6.8
|漏洞来源
https://www.exploit-db.com/exploits/28509
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-200609-216
|漏洞详情
LaurentiuMateieXpandableHomePage(XHP)CMS0.5.1的index.php中存在跨站脚本攻击(XSS)漏洞,远程攻击者可以通过errcode参数注入任意Web脚本或HTML。
|漏洞EXP
source: http://www.securityfocus.com/bid/19948/info

XHP CMS is prone to a cross-site scripting vulnerability because it fails to sufficiently sanitize user-supplied data.

Exploiting this issue could allow an attacker to steal cookie-based authentication credentials and to launch other attacks.

Version 0.5.1 is vulnerable; other versions may also be affected.

http://www.example.com/index.php?errcode=<script>alert(document.cookie);</script>
|参考资料

来源:XF
名称:xhpcms-index-xss(28860)
链接:http://xforce.iss.net/xforce/xfdb/28860
来源:BID
名称:19948
链接:http://www.securityfocus.com/bid/19948
来源:BUGTRAQ
名称:20060911XHPCMSv0.5.1VulsXssandFullpathvuls
链接:http://www.securityfocus.com/archive/1/archive/1/445727/100/0/threaded
来源:VUPEN
名称:ADV-2006-3560
链接:http://www.frsirt.com/english/advisories/2006/3560
来源:SECTRACK
名称:1016823
链接:http://securitytracker.com/id?1016823
来源:SECUNIA
名称:21877
链接:http://secunia.com/advisories/21877
来源:SREASON
名称:1565
链接:http://securityreason.com/securityalert/1565