Simple Machines Forum 'Index.PHP'跨站脚本攻击漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1111328 漏洞类型 跨站脚本
发布时间 2006-10-19 更新时间 2006-10-26
CVE编号 CVE-2006-5503 CNNVD-ID CNNVD-200610-427
漏洞平台 PHP CVSS评分 4.3
|漏洞来源
https://www.exploit-db.com/exploits/28831
https://cxsecurity.com/issue/WLB-2006100134
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-200610-427
|漏洞详情
SimpleMachinesForum(SMF)1.1RC2的index.php中存在跨站脚本攻击漏洞,远程攻击者可以通过action参数注入任意Web脚本或HTML。
|漏洞EXP
source: http://www.securityfocus.com/bid/20629/info

Simple Machines Forum is prone to a cross-site scripting vulnerability because the application fails to properly sanitize user-supplied input. 

An attacker may leverage this issue to have arbitrary script code execute in the browser of an unsuspecting user in the context of the affected site. This may help the attacker steal cookie-based authentication credentials and launch other attacks.

SMF versions 1.1 RC1, 1.1 RC2, and 1.0.8 and prior are vulnerable.

http://www.example.com/index.php?action=login2"><script>alert('xss-by-b0rizQ')</script>
|参考资料

来源:XF
名称:smf-index-xss(29690)
链接:http://xforce.iss.net/xforce/xfdb/29690
来源:BID
名称:20629
链接:http://www.securityfocus.com/bid/20629
来源:BUGTRAQ
名称:20061019[Xss]INSMF1.1RC2
链接:http://www.securityfocus.com/archive/1/archive/1/449241/100/0/threaded
来源:SREASON
名称:1772
链接:http://securityreason.com/securityalert/1772