DirectAdmin多个跨站脚本攻击漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1111519 漏洞类型 跨站脚本
发布时间 2006-11-12 更新时间 2007-04-10
CVE编号 CVE-2006-5983 CNNVD-ID CNNVD-200611-311
漏洞平台 PHP CVSS评分 6.0
|漏洞来源
https://www.exploit-db.com/exploits/29006
https://www.securityfocus.com/bid/21049
https://cxsecurity.com/issue/WLB-2006110088
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-200611-311
|漏洞详情
JBMCSoftwareDirectAdmin存在多个跨站脚本攻击漏洞,远程认证用户可以通过传给在管理员级别中(a)CMD_SHOW_RESELLER或(b)CMD_SHOW_USER的(1)用户参数;传给在用户级别中的(c)CMD_TICKET_CREATE或(d)CMD_TICKET的(2)TYPE参数,传给(e)CMD_EMAIL_FORWARDER_MODIFY,(f)CMD_EMAIL_VACATION_MODIFY或者(g)CMD_FTP_SHOW的(3)用户参数,和传给(h)CMD_EMAIL_LIST的(4)名字参数;或者传给在经销商级别中(i)CMD_SHOW_USER的(5)用户参数,注入任意Web脚本或HTML。
|漏洞EXP
source: http://www.securityfocus.com/bid/21049/info
       
DirectAdmin is prone to multiple cross-site scripting vulnerabilities because it fails to properly sanitize user-supplied input. 
       
An attacker may leverage these issues to execute arbitrary script code in the browser of an unsuspecting user in the context of the affected site. This may help the attacker steal cookie-based authentication credentials and launch other attacks.
       
Versions 1.28.1 and 2.29 are vulnerable; other versions may also be affected.

http://www.example.com:2222/CMD_FTP_SHOW?DOMAIN=demo.com&user=XSS
|受影响的产品
DirectAdmin DirectAdmin 1.28.1 DirectAdmin DirectAdmin 1.29
|参考资料

来源:XF
名称:directadmin-user-xss(30256)
链接:http://xforce.iss.net/xforce/xfdb/30256
来源:BID
名称:21049
链接:http://www.securityfocus.com/bid/21049
来源:BUGTRAQ
名称:20061112DirectAdminMultipleCrossSiteScription
链接:http://www.securityfocus.com/archive/1/archive/1/451376/100/0/threaded
来源:MISC
链接:http://aria-security.net/advisory/directadmin.txt
来源:SREASON
名称:1885
链接:http://securityreason.com/securityalert/1885