B2Evolution 多个跨站脚本攻击漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1111569 漏洞类型 跨站脚本
发布时间 2006-11-16 更新时间 2006-12-01
CVE编号 CVE-2006-6197 CNNVD-ID CNNVD-200611-496
漏洞平台 PHP CVSS评分 6.8
|漏洞来源
https://www.exploit-db.com/exploits/29200
https://cxsecurity.com/issue/WLB-2006120016
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-200611-496
|漏洞详情
b2evolution存在多个跨站脚本攻击(XSS)漏洞,远程攻击者可通过inc/VIEW/errors/内的(a)_404_not_found.page.php,(b)_410_stats_gone.page.php和(c)_referer_spam.page.php内的(1)app_name参数;在(d)inc/VIEW/errors/_404_not_found.page.php内(2)baseurl参数;和在(e)inc/VIEW/errors/_referer_spam.page.php内的(3)ReqURI参数,来注入任意Web脚本或HTML。
|漏洞EXP
source: http://www.securityfocus.com/bid/21334/info
  
The b2evolution application is prone to multiple cross-site scripting vulnerabilities because it fails to properly sanitize user-supplied input. 
  
An attacker may leverage these issues to have arbitrary script code execute in the browser of an unsuspecting user in the context of the affected site. This may help the attacker to steal cookie-based authentication credentials and to launch other attacks.
  
This issue affects b2evolution versions 1.8.2 to 1.9 beta.

http://<www.example.com>/<b2epath>/inc/VIEW/errors/_referer_spam.page.php?ReqURI=[XSS]&app_name=[XSS]
|参考资料

来源:BID
名称:21334
链接:http://www.securityfocus.com/bid/21334
来源:BUGTRAQ
名称:20061128b2evolutionXSSVulnerabilities
链接:http://www.securityfocus.com/archive/1/archive/1/452895/100/0/threaded
来源:SECUNIA
名称:23148
链接:http://secunia.com/advisories/23148
来源:XF
名称:b2evolution-multiple-messages-xss(30562)
链接:http://xforce.iss.net/xforce/xfdb/30562
来源:SREASON
名称:1944
链接:http://securityreason.com/securityalert/1944