BlueCollar i-Gallery 多个跨站脚本攻击漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1111575 漏洞类型 跨站脚本
发布时间 2006-11-16 更新时间 2006-11-28
CVE编号 CVE-2006-6088 CNNVD-ID CNNVD-200611-406
漏洞平台 ASP CVSS评分 4.3
|漏洞来源
https://www.exploit-db.com/exploits/29048
https://cxsecurity.com/issue/WLB-2006110114
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-200611-406
|漏洞详情
BlueCollari-Gallery存在多个跨站脚本攻击(XSS)漏洞,远程攻击者可通过在igallery.asp内的(1)n或(2)d参数,或和搜索相关的(3)未明参数,可能是SearchGallery字段,或者在search.asp内的myquery参数,来注入任意Web脚本或HTML。
|漏洞EXP
source: http://www.securityfocus.com/bid/21122/info

The i-gallery application is prone to multiple-input validation vulnerabilities, including multiple cross-site scripting vulnerabilities and an HTML-injection issue, because the software fails to sufficiently sanitize user-supplied data.

Attacker-supplied HTML and script code would execute in the context of the affected site, potentially allowing the attacker to steal cookie-based authentication credentials or to control how the site is rendered to the user; other attacks are also possible.

This issue affects i-gallery 3.4 and prior versions.

http://target/path/igallery.asp?n=[XSS]
http://target/path/igallery.asp&d=[XSS]
|参考资料

来源:XF
名称:igallery-igallery-xss(30341)
链接:http://xforce.iss.net/xforce/xfdb/30341
来源:BID
名称:21122
链接:http://www.securityfocus.com/bid/21122
来源:BUGTRAQ
名称:20061116i-Gallery3.4CrossSiteScripting
链接:http://www.securityfocus.com/archive/1/archive/1/451854/100/100/threaded
来源:VUPEN
名称:ADV-2006-4584
链接:http://www.frsirt.com/english/advisories/2006/4584
来源:SECUNIA
名称:22952
链接:http://secunia.com/advisories/22952
来源:MISC
链接:http://aria-security.net/advisory/i-Gallery34.txt
来源:SREASON
名称:1912
链接:http://securityreason.com/securityalert/1912