Simple PHP Gallery System 'SP_Index.PHP'跨站脚本攻击漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1111657 漏洞类型 跨站脚本
发布时间 2006-11-24 更新时间 2006-12-04
CVE编号 CVE-2006-6272 CNNVD-ID CNNVD-200612-042
漏洞平台 PHP CVSS评分 6.8
|漏洞来源
https://www.exploit-db.com/exploits/29175
https://www.securityfocus.com/bid/82215
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-200612-042
|漏洞详情
SimplePHPGallery的sp_index.php中存在跨站脚本攻击(XSS)漏洞,远程攻击者可通过dir参数注入任意web脚本或HTML。
|漏洞EXP
source: http://www.securityfocus.com/bid/21278/info

Simple PHP Gallery is prone to a cross-site scripting vulnerability because the application fails to properly sanitize user-supplied input. 

An attacker may leverage this issue to have arbitrary script code execute in the browser of an unsuspecting user in the context of the affected site. This may help the attacker steal cookie-based authentication credentials and launch other attacks.

Version 1.1 is vulnerable to this issue; other versions may also be affected.

http://www.example.com/sp_index.php?dir=[xss]
|受影响的产品
Paul Griffin Simple Php Gallery 1.1
|参考资料

来源:BUGTRAQ
名称:20061124Crosssitescripting&fullpathdisclosure
链接:http://www.securityfocus.com/archive/1/archive/1/452555/100/100/threaded
来源:XF
名称:simple-php-spindex-xss(30490)
链接:http://xforce.iss.net/xforce/xfdb/30490
来源:BID
名称:21278
链接:http://www.securityfocus.com/bid/21278
来源:SREASON
名称:1967
链接:http://securityreason.com/securityalert/1967