CMS Made Simple 'index.php' Search搜索操作跨站脚本攻击漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1111756 漏洞类型 跨站脚本
发布时间 2006-12-11 更新时间 2007-01-03
CVE编号 CVE-2006-6845 CNNVD-ID CNNVD-200612-694
漏洞平台 PHP CVSS评分 6.8
|漏洞来源
https://www.exploit-db.com/exploits/29272
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-200612-694
|漏洞详情
CMSMadeSimple的index.php存在跨站脚本攻击(XSS)漏洞。远程攻击者可以借助于Search搜索操作中的cntnt01searchinput参数注入任意Web脚本或HTML。
|漏洞EXP
source: http://www.securityfocus.com/bid/21527/info

CMS Made Simple is prone to a cross-site scripting vulnerability because the application fails to properly sanitize user-supplied input. 

An attacker may leverage this issue to have arbitrary script code execute in the browser of an unsuspecting user in the context of the affected site. This may help the attacker steal cookie-based authentication credentials and launch other attacks.

http://www.example.com/index.php?mact=Search%2Ccntnt01%2Cdosearch%2C0&cntnt01returnid=51&cntnt01searchinput=Enter+Search..."><script>alert(document.cookie)</script>&cntnt01submit=Submit
|参考资料

来源:BUGTRAQ
名称:20061228Re:XSS-CMSMadeSimplev1.0.2
链接:http://www.securityfocus.com/archive/1/archive/1/455417/100/0/threaded
来源:OSVDB
名称:32571
链接:http://osvdb.org/32571
来源:BID
名称:21527
链接:http://www.securityfocus.com/bid/21527
来源:VUPEN
名称:ADV-2007-0027
链接:http://www.frsirt.com/english/advisories/2007/0027
来源:SECUNIA
名称:23582
链接:http://secunia.com/advisories/23582