Moodle 'discuss.php' 跨站脚本攻击漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1111768 漏洞类型 跨站脚本
发布时间 2006-12-14 更新时间 2006-12-19
CVE编号 CVE-2006-6625 CNNVD-ID CNNVD-200612-389
漏洞平台 PHP CVSS评分 6.8
|漏洞来源
https://www.exploit-db.com/exploits/29284
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-200612-389
|漏洞详情
Moodle的mod/forum/discuss.php中存在跨站脚本攻击漏洞,远程攻击者可以通过navtail参数注入任意Web脚本或HTML。
|漏洞EXP
source: http://www.securityfocus.com/bid/21596/info

Moodle is reported prone to multiple input-validation vulnerabilities, including a cross-site scripting issue and an HTML injection issue, because the application fails to properly sanitize user-supplied input data. 

The cross-site scripting vulnerability is reported to affect version 1.6.1; the HTML-injection vulnerability affects version 1.5.

http://www.exmple.com/moodle/mod/forum/discuss.php?d=1&parent=2&navtail=<script >alert() < img src=& #106& #97& #118& #97& #115& #99& #114& #105& #112& #116& #58& #97& #108& #101& #114& #116& #40& #41>
|参考资料

来源:MISC
链接:http://www.securityfocus.com/data/vulnerabilities/exploits/21596.html
来源:BID
名称:21596
链接:http://www.securityfocus.com/bid/21596