Xt-News 多个跨站脚本攻击(XSS)漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1111820 漏洞类型 跨站脚本
发布时间 2006-12-22 更新时间 2006-12-28
CVE编号 CVE-2006-6746 CNNVD-ID CNNVD-200612-521
漏洞平台 PHP CVSS评分 4.3
|漏洞来源
https://www.exploit-db.com/exploits/29313
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-200612-521
|漏洞详情
Xt-News0.1存在多个跨站脚本攻击(XSS)漏洞。远程攻击者可以借助对(1)add_comment.php或(2)show_news.php的id_news参数,注入任意Web脚本或HTML。
|漏洞EXP
source: http://www.securityfocus.com/bid/21719/info
 
Xt-News is prone to multiple input-validation vulnerabilities, including cross-site scripting and SQL-injection issues, because it fails to sufficiently sanitize user-supplied input.
 
An attacker could exploit these issues to steal cookie-based authentication credentials, compromise the application, access or modify data, or exploit latent vulnerabilities in the underlying database implementation.
 
Version 0.1 is vulnerable to this issue; other versions may also be affected.

http://www.example.com/show_news.php?id_news=[XSS]
|参考资料

来源:BID
名称:21719
链接:http://www.securityfocus.com/bid/21719
来源:BUGTRAQ
名称:20061222Xt-News0.1:SQLInjectionVulnerability&XSS
链接:http://www.securityfocus.com/archive/1/archive/1/455144/100/0/threaded
来源:XF
名称:xtnews-addcomment-xss(31145)
链接:http://xforce.iss.net/xforce/xfdb/31145
来源:VUPEN
名称:ADV-2006-5145
链接:http://www.frsirt.com/english/advisories/2006/5145
来源:SREASON
名称:2058
链接:http://securityreason.com/securityalert/2058
来源:SECUNIA
名称:23456
链接:http://secunia.com/advisories/23456